1. We use cookies to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners. Learn More.

PES 09 problem with ATI Radeon!

Discussion in 'Pro Evolution Soccer - PC' started by RoSmecher, 6 March 2009.

  1. RoSmecher

    RoSmecher Guest

    :FAIL::FAIL::FAIL:

    Hey I recently upgraded my video card to an ATI Radeon 4850.. i have the latest drivers and version 1.2 of PES 09 with Pro Evo Patch..
    For some reason though the game skips and lags terribly when i play.. This did not happen with my older and crappier video card when I played the game..

    any suggestions???
    p.s and yes i did check frame skipping on. :SNACK: :PRAY:
     
  2. Sandopln

    Sandopln Banned

    21 December 2008
    Well Other drivers that are supported with your videocard and others of this series :) I have the same problem with PES 6 with Ati Radeon X 300 Series but i upgraded with NVIDIA Ge Force 8500 GT and now is ok salu :)
     
  3. Majin

    Majin League 1

    23 October 2005
    use D3D Overrider
     
  4. ivanchin99

    ivanchin99 Non-League

    16 October 2008
    If you use ati tray tools, you can simply tick 'triple buffering' in the 3d settings. i had the same problem as you do, the triple buffering solved it :D
     
  5. gram1978

    gram1978 Non-League

    10 August 2007
    I sometimes get an extra instance of CLI.exe spawning while playing (ATI Radeon Xpress), and it absolutely kills the speed of the game.
     
  6. RoSmecher

    RoSmecher Guest

    thanks guys, the problem ended up fixing itself with ati driver version 9.5..

    thanks for all the suggestions and help though, now back to playing PES 09 :BOP:
     

Share This Page

Welcome to Evo-Web! As a guest you can browse some of our forums. If you want to join in the discussions and get full access please sign up here.