1. We use cookies to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners. Learn More.

Ati Mobility Radeon HD 4570 - PES 2010 problems

Discussion in 'Pro Evolution Soccer - PC' started by WEtongelre, 22 November 2009.

  1. WEtongelre

    WEtongelre Champions League

    17 February 2006
    Eindhoven
    Galatasaray
    Hi guys!

    I have a major dillema. I'd installed PES 2010 last night and then I was playing it for the first time. Everything was normal, no stuttering, no delay, nothing... I was really happy with the result.

    Then I went to sleep and in the morning I was playing PES 2010 again... Delays, stuttering, the screen was a bit "blur" but the settings were the same as last night, so I don't understand a * of it!

    I tried a program called "GameGain" for better 3D performans, with no result.

    My computer specs are:

    Dell Studio 1745
    17.3” High Definition+ (1600x900) LED
    Pentium Dual Core 2 T4300 2.10 GHZ - 60hz
    Windows 7 - 64 bit
    Ati Mobility Radeon HD 4570 512 MB

    I don't know what the cause is, because in the settings I've got everything "Good" only my CPU has a "OK".

    I know my laptop is powerfull enough to run PES 2010 fluently on 1600 - 900 resolution (like last night, it was running without one single problem) So I'm a little desperate...

    Sorry for the long story, I hope somebody can help me out of this :)
     
    Last edited: 22 November 2009
  2. Fedayn10

    Fedayn10 Conference

    2 September 2005
    CPU OK is the solution, i'm sorry... I had a Dual Core 2 3.00 GHZand the game lag, now I have a Quad Core 2.66 and PES go fluent... try to improve your Video Card with ATI Catalyst and play with lower details
     
  3. truebrit3

    truebrit3 Non-League

    25 November 2005
    I run it on a p7350 which is not that different, I'm using a ati4650 on a samsung laptop and it runs fine.

    I'd check that you have nothing running in the background like a virus scan or a downloader (maybe windiws update).
    It may be worth rebooting the computer as well;
     
  4. greenmachine

    greenmachine League 1

    5 November 2003
    Im running the game off my Intel graphic chip :) . on shader 2 but it plays with no problems.

    I just got a ATI HD5770 but wouldn't you know it , I need a 6pin PCI cable will have to wait until tomorrow to install it.
     
  5. BillBillson

    BillBillson Banned

    12 January 2009
    The game just does that from time to time mate.

    I have a fairly high spec gaming machine and ProEvo has its little spells of running like shit even on that.

    No reason for it to do so....it just sometimes does....I just restart the game when it does that and it normally fixes it.
     
  6. WEtongelre

    WEtongelre Champions League

    17 February 2006
    Eindhoven
    Galatasaray
    It's like the problem is solved. I turned the compatability to Vista SP 2 and it's far better then normal :)
     
  7. doncherrati

    doncherrati Captain

    7 October 2007
    Hollanda
    As Roma for their shirts,
    hi i have allmost he same specs only on a 15.5 inch and a 4530hd running modern warfare 2 superb but pes 2010 somewhat not smooth. i`ve been scanning the internet for a solution that`d really could work but it`s just luck when it does run smooth.

    well if you find a solution please post it so others could also benefit from it, I will do that too

    Sallam
     
  8. stevann

    stevann League 1

    11 January 2008
    SRBIJA BRE,kakav Kripton koj kurac
    N.Djokovic,Crvena Zvezda
    i have the same problem,but i have ati r5770,and amd athlon dual core 4000+,game was good for few days but now the same problem,i have XP sp3,i tried every program for ati but still have problems,i turned vsync and tripbuf but still not all ok,i had 8600gt before ati and all the time i had 60 fps butt now dont,i have new driver and everything ,even tried ati refresh rate something...help please
     

Share This Page

Welcome to Evo-Web! As a guest you can browse some of our forums. If you want to join in the discussions and get full access please sign up here.